• Willkommen zur 3D-Druck-Community, einer nichtkommerziellen,
  • werbefreien und privaten Plattform rund um das Thema 3D-Drucken
  • vorrangig im deutschsprachigen Raum. Von User für User.
Hallo, Gast! Anmelden Registrieren


Themabewertung:
  • 1 Bewertung(en) - 1 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Octoprint - Heizbett heizt nicht auf
#1
Hi,

ich habe seit 2-3 Wochen meinen ersten 3D-Drucker (einen CTC). Seitdem ich netterweise auf dieses echt geniale Forum hingewiesen wurde, konnte ich schon eine Menge Probleme beheben, aber leider gibt es immer noch einige ungelöste Sachen mit denen ich noch kämpfe. Wink

Ich habe meinen CTC auf die Firmware Sailfish geupdatet. Anfangs habe ich den über die Software MakerBot gesteuert. Nun habe ich das ganze eleganter über Raspberry und Octoprint gelöst. Ich erstelle die Gcodes immer noch mit der MakerBot Software da mir Simplify 3D noch etwas zu kompliziert ist.

Leider habe ich jetzt das Problem, dass sich bei, den gleichen Einstellungen, bei Octoprint nie das Bett auf 100°C vorheizt. Das funktioniert aber wenn ich den Drucker am PC anschließe und über die MakerBot Software starte.
Ich habe mal einen erstellen Gcode als Datei angehängt, falls euch das weiterhilft.

Ich danke euch schon mal für eure Hilfe
Gruß Sepa1818


Angehängte Dateien
.zip   Dart_Rack.zip (Größe: 551,84 KB / Downloads: 4)
 
Reply to top
#2
Hast Du in Octoprint auch das GPX-Plugin eingebunden? Der CTC versteht keinen GCode, der braucht ein anderes Format namens X3G, welches von GPX erzeugt wird...
Gruß
Chris                    

Leuten, welche die ganze Hand nehmen, wenn man ihnen den kleinen Finger gibt,
sollte man nicht die Stirn bieten...


Meine Drucker:
MKC 4.1 mit Beta-Teilen vom MK2 auf X und Y, MKS SBase 1.3 + 2 TMC-2208 auf Zusatzplatine, Smoothieware
MKC MK2, RADDS 1.5 + RAPS 128 + TMC2100 (E) , Repetier 0.92.9
3DDC-Core (beta), MKS Gen 1.4 + TMC2100 (X+Y) + DRV8825, Marlin RC7
Cyclone PCB Factory (CNC Fräse), Arduino Uno + CNC-Shield + A4988, GRBL 1.1f



 
Reply to top
#3
Ja habe ich.
Es funktioniert ja auch ansonsten perfekt, der Druck läuft ansonsten genauso wie es über den MakerBot direkt auch laufen würde. Es ist nur das Heizbett das die Temperatur nicht vorheizt. (jedenfalls habe ich sonst noch keinen Unterschied gefunden)
 
Reply to top
#4
Hast Du das Heizbett im Druckerprofil aktiviert?

   
Wenn ich gerade etwas drucke, dann siehst Du das hier LIVE:
---> http://3dprinter.br0s.de/
---> http://hypercube.br0s.de/
 
Reply to top
#5
Ja habe ich aktiviert.
Ich kann das Heizbett manuell in Octoprint aufheitzen. Das geht bei einem Druckjob aber erst, wenn der angefangen hat zu drucken und dann ist es ja zu spät^^

Hier sind mal meine Einstellungen, ich hoffe mal dass das alle relevanten dafür sind.

[Bild: http://i.imgur.com/WP9j4Tq.jpg]

[Bild: http://i.imgur.com/4w2kbBd.jpg]

[Bild: http://i.imgur.com/R4iM3kD.jpg]

[Bild: http://i.imgur.com/TvEbhTx.jpg]
 
Reply to top
#6
Hmmm ... bei mir steht in den GPX Einstellungen als Machine Type "Flashforge Creator Pro"

Ich weiß nur nicht mehr, warum ich das so eingestellt hatte ...

   

Welche Versionen von Sailfish, Octoprint und GPX hast Du installiert?

Ich hab' hier noch OctoPrint 1.2.16, GPX 2.5.4 und Sailfish 7.7. Damit funktioniert's, wobei ich nicht aus der Makerbot Desktop Software drucke ...

Wenn ich mir Deinen gcode ansehe, fällt mir auf, dass darin gar kein "M140" enthalten ist, der aber für die Temperatur des Heatbeds gebraucht wird.

Ich habe leider absolut keine Ahnung, ob man das in der Makerbot Software ändern kann oder sogar muss oder ob GPX das trotzdem versteht und es wäre in meinem Fall auch egal, da ich Bett und Hotend eh' immer manuell vorher aufheize.

Sorry, da kann ich Dir nicht weiterhelfen und nur den Tipp geben, dass ein vorheriges Aufheizen insofern sinnvoll ist, als dass das Heatbed dann auch komplett bis zur Oberfläche durchgewärmt ist, wobei das bei PLA nicht ganz so wichtig ist wie bei ABS. Je dicker die Aluplatten werden, umso länger darf man vorher manuell aufheizen.

Grüße
Wenn ich gerade etwas drucke, dann siehst Du das hier LIVE:
---> http://3dprinter.br0s.de/
---> http://hypercube.br0s.de/
 
Reply to top
#7
Hey Danke, habe deine Einstellungen mal übernommen und jetzt geht es Smile

Aber das wäre natürlich eine Möglichkeit mit dem Vorheitzen
Ich verwende zwar noch keine Platte auf meinem Druckbett, aber will mich damit auch noch beschäftigen.
Wäre es dann nicht sinnvoll das ganze über die Octoprint Einstellungen GCode Script zu lösen? Dort kann man ja dann einstellen, dass sich Heizbett und Nozzel für eine gewisse Zeit automatisch vorheitzen, bevor der GCode ausgeführt wird.  Ich habe bisher nur in meinr Ausbildung mal kurz mit GCodes für CNC-Maschinen gearbeitet. Vielleicht ist es möglich die Temperatur mit der Heitztemperatur vom nachfolgenden GCode zu verknüpfen. Das werde ich demnächst mal ausprobieren.
 
Reply to top
  


Möglicherweise verwandte Themen...
Thread Verfasser Replies Views Last Post
  [Tipp] OctoPrint auf dem Orange Pi Plus installieren 3D_Joe 55 3.458 Gestern, 16:18
Last Post: J_Weidner
  Octoprint-->Kamera - LowBudget Lösung PrintPiet 20 1.393 19.04.2017, 12:38
Last Post: paradroid
  Octoprint, TouchUI beim Boot auf Display avoid 8 794 25.03.2017, 18:06
Last Post: ColoradoSLim
  Octoprint Kamera kein Bild agentsmith1612 3 145 21.03.2017, 16:00
Last Post: agentsmith1612
  Octoprint über Internet verfügbar machen agentsmith1612 16 398 14.03.2017, 23:36
Last Post: paradroid



Browsing: 1 Gast/Gäste