• Willkommen zur 3D-Druck-Community, einer nichtkommerziellen,
  • werbefreien und privaten Plattform rund um das Thema 3D-Drucken
  • vorrangig im deutschsprachigen Raum. Von User für User.
Hallo, Gast! Anmelden Registrieren


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Problem mit TMC2100 im MKC 4.1
#11
(10.01.2017, 22:25)ChrisB schrieb: Hast Du die Drahtbrücke von CFG1 nach GND gelötet? Wenn nein ist das Verhalten kein Wunder...

Wieso ?
 
Reply to top
#12
Weil du dann soweit ich weiss im "stealthChop" modus bist, der ist zwar leise aber verliert dafür massig an power und er kann schritte verschlucken/überspringen

http://reprap.org/wiki/TMC2100/de

Da sieht man ganz gut wie man die lötbrücke setzten muss für den gewünschten "spreadCycle" modus
 
Reply to top
#13
Auch wenn es hier Leute gibt, die behaupten, das würde gehen, ist der StealthChopModus generell nicht für 3D-Drucker geeignet und man bekommt sehr schnell Schrittfehler. Es mag bei dem einen oder anderen wirklich noch gerade eben klappen, aber die Regel ist das nicht...
Gruß
Chris                    

Man gewöhnt sich an allem, sogar an dem Dativ...
 
Reply to top
#14
Also der StealthChopMode funktioniert, auch beim 3D-Druck, nur sollten da dann auch alle Randbedingungen stimmen. Ich benutze momentan auch TMC's in diesem Modus jedoch nur mit 100mm/s habe aber die Spannung auch auf 1,2V. Wenn die Schlitten etwas schwerer laufen, dann kann es in diesem Modus tatsächlich Probleme geben. Man kann damit aber auch Glücklich werden. Für den Anfang würde ich auf jedenfall erstmal mit dem SpreadCycleMode arbeiten und dann nochmal testen ob die Motoren richtig fahren.
Gruß Thomas

 
Reply to top
#15
(10.01.2017, 23:18)zumili schrieb: Also der StealthChopMode funktioniert, auch beim 3D-Druck, nur sollten da dann auch alle Randbedingungen stimmen. Ich benutze momentan auch TMC's in diesem Modus jedoch nur mit 100mm/s habe aber die Spannung auch auf 1,2V. Wenn die Schlitten etwas schwerer laufen, dann kann es in diesem Modus tatsächlich Probleme geben. Man kann damit aber auch Glücklich werden. Für den Anfang würde ich auf jedenfall erstmal mit dem SpreadCycleMode arbeiten und dann nochmal testen ob die Motoren richtig fahren.

Dann lass es mich anders ausdrücken:

- Wenn ihr bewusst den StealthChopMode einstellt, stellt bitte keine Fragen, warum irgend etwas nicht richtig funktioniert, denn ihr habt die Erklärung schon.
- Wenn ihr TMC2100 verwendet und ihr Schrittfehler bekommt, prüft als erstes, ob die Verbindung zwischen CFG1 und GND (SpreadCycleMode) da ist, sonst liegt da auch der Fehler.
- Wenn ihr bewusst den StealthChopMode einstellt und keine Fehler habt: Glückwunsch, ihr habt entweder viel Glück, oder euren Drucker gut gebaut und im Griff.
Gruß
Chris                    

Man gewöhnt sich an allem, sogar an dem Dativ...
 
Reply to top
#16
Also ich habe eine Draht zwischen CFG1 und GND. Ich habe gestern auch noch versucht beide Motoren mit der Hand fest zu halten. Kraft müssten die Motoren genug haben. Sobald ich zuhause bin mach ich mal ein Bild von den Treibern.


Gesendet von meinem LG-D855 mit Tapatalk
 
Reply to top
#17
also ich hab die TMC2100 silentstepstick nach dieser Anleitung eingebaut in beide MKC´s
http://www.instructables.com/id/Install-and-configure-SilentStepStick-in-RAMPS-TMC/

keine Brücke gemacht und laufen sehr gut.
nur die Jumper entfernt und die Motorstecker gedreht. ansonsten hab ich nichts geändert
 
Reply to top
#18
So hab ich die Brücke bei meinen Treibern gemacht.
So sind sie auch bei meinen Prusa und dort geht es ja auch. Huh
[Bild: http://fs5.directupload.net/images/170111/temp/qmmh27dp.jpg]
Kann es sein das es einen Fehler giebt wenn ich unten die 3 Jumper gesteck habe?
 
Reply to top
#19
ja die jumper unter den triebern müssen alle raus
 
Reply to top
#20
(11.01.2017, 14:57)San Jager schrieb: So hab ich die Brücke bei meinen Treibern gemacht.
So sind sie auch bei meinen Prusa und dort geht es ja auch. Huh
[Bild: http://fs5.directupload.net/images/170111/temp/qmmh27dp.jpg]
Kann es sein das es einen Fehler giebt wenn ich unten die 3 Jumper gesteck habe?

Die gesetzten Jumper sollten kein problem mache, da du ja die Beine am driver weggelassen hast.
Schaut euch auch meine anderen Projekte an:
 
Reply to top
  




Browsing: 1 Gast/Gäste