Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.
  • Willkommen zur 3D-Druck-Community, einer nichtkommerziellen,
  • werbefreien und privaten Plattform rund um das Thema 3D-Drucken
  • vorrangig im deutschsprachigen Raum. Von User für User.
Hallo, Gast! Anmelden Registrieren


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Lüfter regeln mit Marlin - FAST_PWM_FAN -
#1
Wertes Forum!

Mein 5015 Radiallüfter ließ sich nicht zufriedenstellend als Bauteillüfter in der Drehzahl regeln. Ebenso hatte er Anlaufschwierigkeiten.
Ich will ihn jetzt nicht schlecht reden, aber so konnten wir keine Freunde werden.

https://www.amazon.de/gp/product/B01N9ZMRUR/ref=oh_aui_detailpage_o01_s02?ie=UTF8&psc=1


Um den Zustand zu verbessern bin ich mal wie folgt vorgegangen:

1. Schritt: #define FAN_SOFT_PWM

In der Marlin Konfiguration habe ich die Software PWM aktiviert.

Ergebnis: Weiterhin magere Anlauffreude im unteren Bereich. Der Lüfter ließ sich aber etwas besser regeln, erzeugte dabei aber ein störendes Geräusch.
Um dem auf den Grund zu gehen habe ich das Oszi angeklemmt.

   

Marlin generiert in diesem Modus eine PWM mit etwa 7.7Hz. Diese Frequenz läßt sich in dem Geräusch gut ausmachen, womit dessen Ursache zugeordnet werden kann.

Mit SOFT_PWM_SCALE kann man diese Frequenz auf Kosten der Auflösung mäßig vergrößern. Hierbei ist allerdings der nichtlineare Zusammenhang zur Kühlleistung zu berücksichtigen. Eigentlich bräuchte man im unteren Bereich kleinere Stufen als oben. Die Stufen sind aber gleich groß, weshalb eine geringere Auflösung merkliche Nachteile mit sich bringt.
Code:
   // SOFT_PWM_SCALE to frequency:
   //
   // 0: 16000000/64/256/128 =   7.6294 Hz
   // 1:                / 64 =  15.2588 Hz
   // 2:                / 32 =  30.5176 Hz
   // 3:                / 16 =  61.0352 Hz
   // 4:                /  8 = 122.0703 Hz
   // 5:                /  4 = 244.1406 Hz


2. Schritt: Glättungskondensator einsetzen

Der erste mir in die Finger geratene Elko erschien mir mit 470uF zwar recht hoch, musste aber trotzdem herhalten.

Ergebnis: Das Anlaufverhalten ist besser, das Geräusch nicht wirklich unauffälliger.
Was sagt das Oszi:

   

In der schnell abfallenden Flanke erkennt man, daß die Kapazität nicht ausreicht, um eine zufriedenstellende Glättung zu erreichen.
Noch größere Kapazitätswerte wollte ich dennoch nicht testen, da die Strombelastung der Boardausgänge auch nicht unbegrenzt ist bzw. ich dazu keine Angaben habe.

3. Schritt #define FAST_PWM_FAN

Code:
// Increase the FAN PWM frequency. Removes the PWM noise but increases heating in the FET/Arduino
#define FAST_PWM_FAN

// Use software PWM to drive the fan, as for the heaters. This uses a very low frequency
// which is not as annoying as with the hardware PWM. On the other hand, if this frequency
// is too low, you should also increment SOFT_PWM_SCALE.
//#define FAN_SOFT_PWM


Dieser Modus hat eine wesentlich höhere PWM-Frequenz, was man im Geräusch sofort angenehm bemerkt.
Ohne Elko ergeben sich bei meinem Lüfter trotzdem wieder Anlaufschwierigkeiten.

Zur Dimensionierung des Elkos habe ich folgende Überlegungen angestellt:

Um bei Bedarf die Drehzahl möglich klein einstellen zu können, lautet die erste Forderung
Sicherer Anlauf an der 1%-Marke.
Daher Elko hinreichend groß dimensionieren.

Um den tatsächlichen Regelbereich möglichst groß zu halten, lautet die zweite Forderung
Elko möglichst klein dimensionieren, da sich mit größer werdender Kapazität der Regelbereich verkleinert und die Strombelastung vergrößert.

Ergebnis:
Bis 47uF ergeben sich noch Fehlanläufe.
Ab 100uF ist der Rundlauf akustisch stabil.
Der Regelbereich geht noch bis ca 50%.
Über 50% ist nahezu kein Drehzahlgewinn mehr auszumachen.


Fazit: In diesem Modus ist der Lüfter (mit Glättungskondensator) gut einzusetzen.

Da ich zum Aufbau des Lüfterausgangs auf dem Melzi des CR-10 aber keine Daten habe,
bleibt noch offen, ob es zu einer thermischen Überlastung kommen kann.
Gruß
Clyde
 
to top
#2
wenn du mehr als 100uF brauchst, dann ist der lüfter kacke^^
Da sind wohl die lager nicht mehr gut, und dann wird der kondensator auch nur noch für kurze zeit helfen, das wird ja nicht von selbst wieder besser.

bei problemen mit dem anlaufen gibt man dem lüfter kurz 100% pwm und regelt dann auf das tastverhältnis was man möchte.
Dachte repetier firmware hat das sowiso mit drinn, ohne das man was machen muss (ich las da neulich was im quelltext)

zum kondensator: das ist eigentlich ne "erfindung" für lüfter die bei kleinen tastverhältnix zur herumzuppeln und gar nicht laufen wollen (so unter 50%), um die noch weiter runter regeln zu können. Je größer die kapazität, desto schlechter sprechen sie auf änderungen des tastverhältnis an. Deshalb gilt hier "weniger ist mehr", und "so viel wie nötig, so wenig wie möglich".
Ein Leben ohne 3D-Druck ist möglich, aber sinnlos.
 
to top
#3
Der Lüfter ist "neu", jedenfalls behauptet Amazon dies. Deshalb war ich auch enttäuscht wegen des schlechten Anlaufverhaltens. Scheint bei den Radiallüftern aber häufiger vorzukommen, denn ich habe das die Tage jetzt schon öfter gelesen.

Mit dem Elko läuft er jetzt prima. Allerdings etwas zu gut, denn daneben läßt sich nicht mehr vernünftig arbeiten. Mit dem Petsfang klingt es nun, als sitzt man in einem Haarstudio. :-)

Ich werde noch andere Lüfter/Fanducts probieren und evtl. auch mal Axiallüfter probieren.
Gruß
Clyde
 
to top
#4
axiallüfter sind von der luftmenge her nur für den "free air" einsatz gut, also wenn die luft nahezu ungehindert fließen kann.
Will man sie durch kleine löcher drücken, dann lässt die wirkung aufgrund des staudrucks schnell nach.

An der stelle können radiallüfter besser funktionieren, weil die im prinzip einen höheren druck aufbauen.

Natürlich kommt es auf das genaue modell drauf an.
Schau dir von lüfterchen die datenblätter an, und vergleiche den mmWs parameter (gibts auch einen imperialen wert dafür)

Die maximal erreichbare druckdifferenz (in millimeter wassersäule) ist bei dem einsatz am fanduct mit "luft durch ein kleines loch drücken" wesentlich für den luftdurchsatz an der düse. Da es im prinzip eine düse ist, erhöht sich der luftstrom mit dem druck überproportional. Also doppelter druck = mehr als doppelter durchsatz.

Leider stellt man dann schnell ernüchtert fest, das die lüfterchen mit guten druckwerten leider auch die sind, die hohe drehzahlen und hohes laufgeräusch verursachen.
Ein Leben ohne 3D-Druck ist möglich, aber sinnlos.
 
to top
#5
In der Tat. Die Frage ist ja, wieviel hinreichend ist?

Also bei meinem CR-10 bewegt sich das Bett in Y, daher kann ich eh nicht so fix drucken, was die Anforderungen etwas nach unter setzt. PLA sollte aber schon gut gekühlt werden können.

Der Stock-Fan ist ein radialer 4010 Lüfter.

Mein gegenwärtiges Setup hat einen 5015er Radiallüfter und ist sehr laut.
Es scheint mir auch etwas überdimensioniert zu sein, da ich damit auch
in der kleinsten Einstellung (1%) nicht nennenswert schlechter drucke als in der höchsten.

Da ich den 5015er nicht wirklich leise bekomme, möchte ich noch ein Setup mit Axiallüftern testen.
Auch wenn die prinzipiell da nicht für geeignet sind probiere ich das mal aus.
Die Axiallüfter sind besser zu bekommen und haben eine größere Auswahl.

Plan C wäre dann noch ein Setup mit 2 radialen 4010er Lüftern.
Gruß
Clyde
 
to top
#6
ich hab an meinen "um clone" für die bauteilkühlung diesen lüfter verwendet:
http://www.reichelt.de/FAN-ML-4010-12-P/3/index.html?&ACTION=3&LA=446&ARTICLE=133493&artnr=FAN-ML+4010-12+P&SEARCH=l%FCfter+40+40+10

der bringt 6,1 mmWs
ist aber auch nicht ganz leise, und die a99-maglev lüfterchen laufen mit PWM nicht ohne einen kleinen elko.
Keine ahnung ob es da vielleicht noch besseres gibt, die sind billig, bringen ganz gut luftdruck und gehen nicht so schnell kaputt wie die 1-dollar-chinalüfterchen.
Wenn man platz hat könnte man auch die doppelt (20mm) dicken axiallüfterchen verwenden, die haben bei gleicher drehzahl auch mehr druck als die dünnen (immer datenblätter vergleichen, weil es von jeder mechanischen größe meist mehrere motorisierungen gibt)
Ein Leben ohne 3D-Druck ist möglich, aber sinnlos.
 
to top
#7
Hallo Leute

habe auch das Problem mit meine Axiallüfter
läuft nur mit 100% an und dann läst sich die Drehzahl auch nicht regeln (nur 100%)
dann habe ich

https://www.amazon.de/gp/product/B01N6Z3L7G/ref=oh_aui_detailpage_o04_s00?ie=UTF8&psc=1

kann ich da was an der Software ändern oder einen anderen kaufen ?
das steht bei mir in Marlin
Code:
#define FAN_SOFT_PWM

   // SOFT_PWM_SCALE to frequency:
   //
   // 0: 16000000/64/256/128 =   7.6294 Hz
   // 1:                / 64 =  15.2588 Hz
   // 2:                / 32 =  30.5176 Hz
   // 3:                / 16 =  61.0352 Hz
   // 4:                /  8 = 122.0703 Hz
   // 5:                /  4 = 244.1406 Hz
   pwm_count = pwm_count_tmp + _BV(SOFT_PWM_SCALE);

 #else // SLOW_PWM_HEATERS
schon mal danke
  Rainer
Creality CR10 S
 
to top
#8
Hast Du denn schon mal die anderen Werte für SOFT_PWM_SCALE durchprobiert? Da sollte es irgendwo noch eine Zeile mit
Code:
#define SOFT_PWM_SCALE 0

geben, wo Du statt der 0 andere Werte angeben kannst.
Gruß
Chris                    

Meine Schwiegermutter hat viel mit Konfuzius gemein,
nur das "z" wurde zum "s"...
 
to top
#9
Hi
habs versucht
Code:
#define SOFT_PWM_SCALE 0
Werte von 1-20 eingegeben der Lüfter läuft nur bei 255 (100%)

Gruß
Rainer
Creality CR10 S
 
to top
#10
0-5 hätte gereicht:

Code:
  // SOFT_PWM_SCALE to frequency:
   //
   // 0: 16000000/64/256/128 =   7.6294 Hz
   // 1:                / 64 =  15.2588 Hz
   // 2:                / 32 =  30.5176 Hz
   // 3:                / 16 =  61.0352 Hz
   // 4:                /  8 = 122.0703 Hz
   // 5:                /  4 = 244.1406 Hz

Du kannst auch mal einen Kondensator parallel zum Lüfter versuchen... Aber es ist halt so, dass das nicht mit jedem Lüfter funktioniert.
Gruß
Chris                    

Meine Schwiegermutter hat viel mit Konfuzius gemein,
nur das "z" wurde zum "s"...
 
to top
  


Möglicherweise verwandte Themen...
Thread Verfasser Replies Views Last Post
  Ramps 1.4 und Lüfter r4ph4 7 360 07.03.2019, 12:14
Last Post: c1olli
  MKS 1.4 24V -> 12V PWM Lüfter ansteuern + Coolend Temp + Lüfter Auslegung FendtFan 17 1.132 19.12.2018, 18:06
Last Post: c1olli
  PWM und Lüfter - Stepdown Problem StefanMe 12 2.612 30.05.2018, 23:36
Last Post: Kookaburra88
  "Israel" Lüfter? StefanMe 3 1.449 23.03.2018, 19:46
Last Post: andy5macht
  An einem Tag, zwei Hotend Lüfter kaputt PSyHotrod 17 2.757 16.03.2018, 17:15
Last Post: PSyHotrod



Browsing: 1 Gast/Gäste