Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.
  • Willkommen zur 3D-Druck-Community, einer nichtkommerziellen,
  • werbefreien und privaten Plattform rund um das Thema 3D-Drucken
  • vorrangig im deutschsprachigen Raum. Von User für User.
Hallo, Gast! Anmelden Registrieren


Themabewertung:
  • 1 Bewertung(en) - 5 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[Info] Info SKR v1.3
Ganz klares "Jain"!

Marlin und Klipper brauchen die Karte (mWn.) nicht, Smoothieware liest die "config.txt" von der SD-Karte und würde ohne nicht funktionieren.
Gruß
Chris                    

Meine Schwiegermutter hat viel mit Konfuzius gemein,
nur das "z" wurde zum "s"...
 
to top
Ich bekomme am SKR irgendwie das 12864 Display nicht ans laufen, gibt es da ggfs. bekannte Probleme wenn man SPI Treiber nutzt?
Zu der EXP1 und EXP2 Belegung am Display bekommt man bei google auch 50 verschiedene Varianten, da wohl jeder Hersteller hier seine eigene Belegung nutzt.
Leider bekomme ich aber nichtmals Spannung aufs Display, das Display bleibt komplett schwarz.
Firmware ist Klipper, wobei das hier denk ich erstmal nachgelagert ist.
Grüße,
Jannis

- 9 von 10 Stimmen in meinem Kopf sagen, ich sei verrückt. Die 10te summt die Melodie von Tetris. -
 
to top
Ohne die Config zu sehen, kann man da kaum etwas zu sagen... Generell sollte das gehen, aber dunkel sollte es nicht bleiben! Hast Du die Stecker - hinsichtlich der Pinbelegung und nicht der Nasen - richtig herum drauf?
Gruß
Chris                    

Meine Schwiegermutter hat viel mit Konfuzius gemein,
nur das "z" wurde zum "s"...
 
to top
Hier die Config:

Code:
[stepper_x]
step_pin: P2.2
dir_pin: P2.6
enable_pin: !P2.1
step_distance: .0125
endstop_pin: ^!P1.29  # P1.28 for X-max
position_endstop: 0
position_max: 205
homing_speed: 70

[stepper_y]
step_pin: P0.19
dir_pin: P0.20
enable_pin: !P2.8
step_distance: .0125
endstop_pin: ^!P1.27  # P1.26 for Y-max
position_endstop: 0
position_max: 180
homing_speed: 70

[stepper_z]
step_pin: P0.22
dir_pin: P2.11
enable_pin: !P0.21
step_distance: .000625
endstop_pin: ^!P1.25  # P1.24 for Z-max
position_endstop: 0
position_max: 200

[extruder]
step_pin: P2.13
dir_pin: P0.11
enable_pin: !P2.12
step_distance: .002468
#.002493
nozzle_diameter: 0.400
filament_diameter: 1.750
heater_pin: P2.7
sensor_type: PT100 INA826
sensor_pin: P0.2
control: pid
pid_Kp: 21.723
pid_Ki: 0.805
pid_Kd: 146.629
min_temp: 0
max_temp: 250
pressure_advance: 0.860
pressure_advance_lookahead_time: 0.015

[heater_bed]
heater_pin: P2.5
sensor_type: ATC Semitec 104GT-2
#sensor_type: EPCOS 100K B57560G104F
sensor_pin: P0.23
control: pid
pid_Kp: 69.078
pid_Ki: 1.084
pid_Kd: 1100.933
min_temp: 0
max_temp: 100

[fan]
pin: P2.3
shutdown_speed: 0
kick_start_time: 0.100

[mcu]
serial: /dev/serial/by-path/platform-3f980000.usb-usb-0:1.1.3:1.0

[printer]
buffer_time_high: 30
kinematics: corexy
max_velocity: 300
max_accel: 2000
max_z_velocity: 5
max_z_accel: 15


[tmc2130 stepper_x]
cs_pin: P1.17
spi_software_sclk_pin: P0.4
spi_software_mosi_pin: P4.28
spi_software_miso_pin: P0.5
#spi_speed: 100000
microsteps: 16
#diag1_pin: P1.29
run_current: 0.800
hold_current: 0.500
stealthchop_threshold: 80
#sense_resistor: 0.110

[tmc2130 stepper_y]
cs_pin: P1.15
spi_software_sclk_pin: P0.4
spi_software_mosi_pin: P4.28
spi_software_miso_pin: P0.5
#spi_speed: 100000
microsteps: 16
#diag1_pin: P1.27
run_current: 0.800
hold_current: 0.500
stealthchop_threshold: 80
#sense_resistor: 0.110

[tmc5160 stepper_z]
cs_pin: P1.10
spi_software_sclk_pin: P0.4
spi_software_mosi_pin: P4.28
spi_software_miso_pin: P0.5
#spi_speed: 100000
microsteps: 16
#diag1_pin: P1.29
run_current: 0.800
hold_current: 0.500
stealthchop_threshold: 80
#sense_resistor: 0.110

[tmc5160 extruder]
cs_pin: P1.8
spi_software_sclk_pin: P0.4
spi_software_mosi_pin: P4.28
spi_software_miso_pin: P0.5
#spi_speed: 100000
microsteps: 16
#diag1_pin: P1.29
run_current: 0.800
hold_current: 0.500
stealthchop_threshold: 80
#sense_resistor: 0.110

# "RepRapDiscount 128x64 Full Graphic Smart Controller"    
    
[display]
lcd_type: st7920
cs_pin: P1.19
sclk_pin: P1.20
sid_pin: P1.18
encoder_pins: ^P3.26, ^P3.25
click_pin: ^!P0.28
    
#
# Macros:
#

# M600: Filament Change.  This macro will pause the printer, move
# the tool to the change position, and retract the filament 300mm.
# After filament has been changed, the print can be resumed from
# its previous position with the "RESUME" gcode
[gcode_macro M600]
default_parameter_X: 50
default_parameter_Y: 0
gcode:
PAUSE
G91
G1 E-.8 F2700
G1 Z{Z}
G90
G1 X{X} Y{Y} F3000
G91
G1 E-300 F1000
G90

[gcode_macro LOAD]
gcode:
M117 F-FEED...
M109 S210
G91
G1 E50 F2000
G1 E50 F2000
G1 E50 F2000
G1 E50 F2000
G92 E0
G1 E50 F2000
G1 E50 F2000
G1 E50 F2000
G1 E50 F2000
G92 E0
G1 E50 F2000
G1 E50 F2000
G1 E50 F2000
G1 E50 F2000
G92 E0
G90
G1 E10 F200
G92 E0
M104 S0
M18
G4 P2000
M117 fertig...

[gcode_macro UNLOAD]
gcode:
M117 Filament auswerfen...
M109 S210
T0
G92 E0
M83
G1 E5 F200
G92 E1
G1 E-50 F2000
G1 E-50 F2000
G1 E-50 F2000
G1 E-50 F2000
G92 E0
G1 E-50 F2000
G1 E-50 F2000
G1 E-50 F2000
G1 E-50 F2000
G92 E0
G1 E-50 F2000
G1 E-50 F2000
G1 E-50 F2000
G1 E-50 F2000
M104 S0
G90
G92 E0
M18
M117 erledigt...

# G28: homeing Prozedur anpassen
[homing_override]
set_position_z: 0
axes: z
gcode:
    G90  
    G1 Z10 F600
    G28 X0 Y0
    G1 X10 Y10 F3600
    G28 Z0

Ich bin mir bei den Steckern nicht wirklich sicher, ich hab schon diverse Kombinationen ausprobiert, war aber eigentlich davon ausgegangen das es identisch zum vorher verbauten MKS Gen L funktionieren sollte. Da ich aber nicht mals Spannung auf das Display bekomme, denke ich das es irgendwo an der Verkabelung liegt und nicht an der Config, die 5V und GND sollte er ja so oder so bekommen oder gibt es auch beim Display ein Enable oder dergleichen?
Zum 12864 finde ich wie gesagt 1000 und eine Dokumentation über verschiedene Pinouts an EXP1 und EXP2, eigentlich war ich davon ausgegangen das es das basic RepRap ist, aber welches Pinout ist das dann?
Grüße,
Jannis

- 9 von 10 Stimmen in meinem Kopf sagen, ich sei verrückt. Die 10te summt die Melodie von Tetris. -
 
to top
eigentlich hast du dir deine Frage ja schon selber beantwortet wenn du dir das Pinout anschaust.
theoretisch müsstest du jeweils einen Stecker vom Flachbandkabel auf machen und diesen um 180° drehen.


Angehängte Dateien Bild(er)
   
 
to top
Schneide die Nasen an der Boardseite der Kabel ab und stecke sie "verkehrt herum" auf... Die Boards sind "MKS"-ähnlich und haben die Buchsen umgedreht. Da passiert auch nichts, wenn man die mal verkehrt herum ansteckt oder sogar vertauscht.
Gruß
Chris                    

Meine Schwiegermutter hat viel mit Konfuzius gemein,
nur das "z" wurde zum "s"...
 
to top
Es sei denn man vertauscht 5v und Ground.
Was beim einfachen Stecker drehen natürlich nicht passieren Kann/Sollte
Gruß Andreas
____________________________________________

Wer alle Schreibfeller findet bekommt ein Leike von mir  Smile
 
to top
Die Nasen muss man nicht abschneiden, mit etwas Geduld bekommt man die auch verdreht rein. Oder man hebt die Wanne ab und dreht diese.
Chaos is found in greatest abundance wherever order is being sought.
It always defeats order, because it is better organized.
Terry Pratchett
 
to top
Ich nutze da immer die Radikalmethode und schneide mit einem Miniseitenschneider eine entsprechende Einkerbung in die gegenüber liegende Seite der Wanne.
Zynismus ist der geglückte Versuch, die Welt zu sehen, wie sie wirklich ist.

Müll kann man nicht trennen, der hat nur eine Silbe.
 
to top
Ok, hab die Nasen boardseitig an EXP1 und EXP2 abgeschnitten, beide 180 Grad gedreht eingesteckt und bekomme nun immerhin Spannung ans Display.
Leider kommt aber weder Bild noch bekomme ich das Dauerpiepen des Beepers weg. Sad

Hier der entsprechende Configauszug so wie er aktuell ist, eigentlich unverändert aus

https://github.com/KevinOConnor/klipper/blob/master/config/generic-bigtreetech-skr-v1.3.cfg

und

https://github.com/KevinOConnor/klipper/blob/master/config/sample-lcd.cfg

entnommen.

Code:
# "RepRapDiscount 128x64 Full Graphic Smart Controller"

[board_pins]
aliases:
   # EXP1 header
   EXP1_1=P1.30, EXP1_3=P1.18, EXP1_5=P1.20, EXP1_7=P1.22, EXP1_9=<GND>,
   EXP1_2=P0.28, EXP1_4=P1.19, EXP1_6=P1.21, EXP1_8=P1.23, EXP1_10=<5V>,
   # EXP2 header
   EXP2_1=P0.17, EXP2_3=P3.26, EXP2_5=P3.25, EXP2_7=P1.31, EXP2_9=<GND>,
   EXP2_2=P0.15, EXP2_4=P0.16, EXP2_6=P0.18, EXP2_8=<RST>, EXP2_10=<NC>
   # Pins EXP2_1, EXP2_6, EXP2_2 are also MISO, MOSI, SCK of bus "ssp0"

[display]
lcd_type: st7920
cs_pin: EXP1_4
sclk_pin: EXP1_5
sid_pin: EXP1_3
encoder_pins: ^EXP2_3, ^EXP2_5
click_pin: ^!EXP1_2
#kill_pin: ^!EXP2_8

[output_pin beeper]
pin: EXP1_1
Das Display war irgendwann mal bei einem Ramps dabei, sollte soweit ich das sehe eins nach dem Reprap Schema sein und nicht Creality oder ähnliches.
Grüße,
Jannis

- 9 von 10 Stimmen in meinem Kopf sagen, ich sei verrückt. Die 10te summt die Melodie von Tetris. -
 
to top
  


Möglicherweise verwandte Themen...
Thread Verfasser Replies Views Last Post
  Info GT2560 j0k3r 10 2.772 28.10.2017, 21:56
Last Post: j0k3r



Browsing: 1 Gast/Gäste