Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.
  • Willkommen zur 3D-Druck-Community, einer nichtkommerziellen,
  • werbefreien und privaten Plattform rund um das Thema 3D-Drucken
  • vorrangig im deutschsprachigen Raum. Von User für User.
Hallo, Gast! Anmelden Registrieren


Themabewertung:
  • 1 Bewertung(en) - 5 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[Info] Info SKR v1.3
#41
Nein, ist nur AUX-1, wobei die Pins so verbogen sind, dass die Wanne schief gezogen wurde. Das ist aber schon bei der Bestückung passiert, was auch an den Lötstellen zu sehen ist.

Ich bin gerade dabei  das Board auf Funktion zu testen und dabei fiel mir auf, dass zum SKR 1.1 die Ports EXP1 und EXP2 in der Position getauscht wurden - also ist es kein 1:1-DropIn-Replacement, aber es passiert auch nichts schlimmes, wenn man die Kabel vertauscht aufsteckt.

Ich muss jetzt erst einmal alle Ports kontrollieren, da das Display nicht mit der Konfiguration des v1.1-Boards mit Klipper läuft und auch mit der Marlin-Konfiguration das GLCDisplay nicht zum Leben erweckt wurde.

PS: Puuhhhh, die haben ja wirklich *alles* geändert. Ich hatte schon einen Knoten im Hirn, nachdem ich die Treiber-Anschlüsse und Endstops kontrolliert habe, aber das Display macht mir richtig zu schaffen!

PPS: Geschafft, Display läuft...

PPPS: So, jetzt habe ich es schon mal unter Klipper soweit am Laufen, wie vorher das v1.1.
Gruß
Chris                    

Meine Schwiegermutter hat viel mit Konfuzius gemein,
nur das "z" wurde zum "s"...
 
to top
#42
Als kleine Hilfe für den Einstieg in Klipper mit dem Board. Die Konfiguration für die TMC-Treiber und die diversen Extras sind da noch nicht drin!


Angehängte Dateien
.txt   generic-bigtreetech-skr-v1.3.cfg.txt (Größe: 1,8 KB / Downloads: 160)
Gruß
Chris                    

Meine Schwiegermutter hat viel mit Konfuzius gemein,
nur das "z" wurde zum "s"...
 
to top
#43
Ich probiere gerade über die RX/TX Pins im AUX1 Anschluss mit dem Board zu kommunizieren (USB funktioniert). Mein angeschlossener Octopi ist konfiguriert da etwas zu finden, kann aber keine Verbindung aufbauen, als wäre nichts angeschlossen. In Marlin scheinen diese Zeilen in der configuration.h wichtig zu sein:
Code:
/**
* Select the serial port on the board to use for communication with the host.
* This allows the connection of wireless adapters (for instance) to non-default port pins.
* Note: The first serial port (-1 or 0) will always be used by the Arduino bootloader.
*
* :[-1, 0, 1, 2, 3, 4, 5, 6, 7]
*/
#define SERIAL_PORT 0
/**
 * Select a secondary serial port on the board to use for communication with the host.
 * This allows the connection of wireless adapters (for instance) to non-default port pins.
 * Serial port -1 is the USB emulated serial port, if available.
 *
 * :[-1, 0, 1, 2, 3, 4, 5, 6, 7]
 */
#define SERIAL_PORT_2 -1

Man kann entgegen der Beschreibung nur Werte von -1 bis 3 eintragen, aber egal was ich ausprobiere kann Octopi das Mainboard nicht finden. Wo kann ich überhaupt herausfinden was Marlin unter den verschiedenen Pin Nummern versteht? In der pins.h zu dem Board finde ich keine Hinweise wo das definiert wird...
 
to top
#44
Mit Marlin kann ich dir zwar nicht helfen, aber hast Du die Kommunikation mit den Raspi vorher irgendwie anders ausprobiert? Normalerweise liegt beim Raspi (3/3B+) der Bluetooth da drauf und muss vorher erst freigegeben werden (Änderung in der config.txt usw.).
Gruß
Chris                    

Meine Schwiegermutter hat viel mit Konfuzius gemein,
nur das "z" wurde zum "s"...
 
to top
#45
Ja, das habe ich schon alles erledigt, er scannt bereits auf den Ports um die richtige Baudrate herauszufinden, aber da kommt keine Reaktion.

Edit: Habs hinbekommen, aus irgendeinem Grund muss man die zweite serielle Verbindung deaktivieren, genaueres hier: https://www.3d-druck-community.de/showthread.php?tid=26176&pid=190070#pid190070
 
to top
#46
Moin! Hab das Board auch gerade erhalten. Kann mir einer sagen, wie ich die Jumper jetzt setzen muss, um die mitgelieferten TMC2208 zu verwenden? Irgendwie verwirrt mich das PDF mehr, als es für Klarheit sorgt...
 
to top
#47
Sollen die TMC2208 im Standalone oder UART-Modus betrieben werden?

Da diese zum Board dazu bestellt wurden gehe ich von UART aus und dann sind die Jumper wie im Handbuch Seite 11 beschrieben zu setzen.

Im Handbuch ist Standalone-Modus (STEP/DIR), UART und SPI beschrieben, die TMC2208 mögen gern UART haben.
 
to top
#48
Müssen dann die anderen Jumper entfernt werden?
 
to top
#49
Ja, die zwischen den Sockeln sind für das Microstepping, das machst du bei UART und SPI ja via Firmware/GCODE. Die Jumper oberhalb der Endstops (SPI) müssen auch runter.

Welche drauf bleiben müssen ist doch im Handbuch für jeden Betriebsmodus eindeutig farbig markiert.
 
to top
#50
(26.03.2019, 16:01)CrazyIcecap schrieb: Irgendwie verwirrt mich das PDF mehr, als es für Klarheit sorgt...

Definitiv!

Mein erster Gedanke als ich das PDF und das Board in Händen hielt, war, dass da eine Frage-Welle sonder Gleichen auf uns zu kommt. Dein Posting bestätigt das. Das ist kein Board für Anfänger! Die meisten Leute haben ja schon Probleme mit den normalen drei Jumpern, aber hier müssen ja sogar die lange grübeln, die das Thema durchschauen!

Vielleicht findet sich ja ein Doofer, der alle möglichen Konstellationen bebildert dokumentiert Sick Der Tipp von @Riff-Raff ist zwar korrekt, aber die Endstop-Jumper auf dem Bild stimmen mMn. nicht - die müssten gesetzt sein. Und wie muss dann die Software dazu eingestellt werden? Mit der mitgelieferten Marlin-Version wird das wahrscheinlich nicht klappen...

Mir ist schon klar, warum die Chinesen nur auf die Smoothieware-Doku und Marlin-Sourcen auf Github verweisen! Die Möglichkeiten des Boards sind schon gut, aber support-seitig ist es eine Katastrophe.

Und die mitgelieferten Treiber? Wie sehen die denn aus und wo sind die denn bitte dokumentiert? Da kann man dann nur raten...

PS: Die Treiber bestimmen nämlich, welche Jumper gesetzt werden müssen!
Gruß
Chris                    

Meine Schwiegermutter hat viel mit Konfuzius gemein,
nur das "z" wurde zum "s"...
 
to top
  


Möglicherweise verwandte Themen...
Thread Verfasser Replies Views Last Post
  Info GT2560 j0k3r 10 2.927 28.10.2017, 21:56
Last Post: j0k3r



Browsing: 1 Gast/Gäste