Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.
  • Willkommen zur 3D-Druck-Community, einer nichtkommerziellen,
  • werbefreien und privaten Plattform rund um das Thema 3D-Drucken
  • vorrangig im deutschsprachigen Raum. Von User für User.
Hallo, Gast! Anmelden Registrieren


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
SKR V1.3 & TMC2208 Motorüberhitzung
#1
Moin,
ich bin gerade dabei auf das SKR V1.3 und TMC2208 UART mit Marlin 2.0 umzusteigen. Alles lief sogar besser und einfacher als erwartet und alles läuft soweit. Kurz vorab: Ich habe 2 Z Stepper und warte aktuell noch auf einen Y-Adapter. Also dachte ich, dass ich doch einfach in Marlin den "dual z driver"-Modus aktiviere, und den freien E1-Port nutze. Dann hab ich prophylaktisch die Spannung in Marlin für beide(!) Treiber auf 400mA (RMS) reduziert, und alle anderen Treiber auf 800mA gelassen.

Beim Testen ist mir aufgefallen, dass der Stepper der auf E1 liegt sich gefühlt leicht schneller bewegt als der andere Z-Stepper. Dann habe ich einfach mal nen Calibration Cube zum Test gedruckt und in Z-Richtung hat natürlich nichts gepasst.
Aber nun das größte Problem, der Motor der auf E1 liegt wurde in den 10 Minuten bis zum Druckabbruch so heiß (am Motorgehäuse 80°C gemessen), dass sich die PLA Motorhalterung schon verformt hat. Der andere Z-Stepper blieb allerdings angenehm kühl.

Ich habe, gerade bei der Z-Achse, keine Erklärung für eine Überlast o.Ä. aber vielleicht habt ihr ja eine Idee woran es liegt?
Gruß
Julian

 
to top
#2
Ich zitiere mich mal selber:

"Ich wollte also das Ganze nochmal mit Marlin testen, stellte dann aber fest, dass ein Motor der Z-Achse nicht angesteuert wurde. X,Y, und Dual-Z sind mit TMC2208 bestückt und laufen im Uart-Modus. Ich hatte Marlin schon auf dem SKR laufen, allerdings noch mit A4988 bestückt, was auch funktionierte. Zwar ließen sich alle TMC auslesen, jedoch scheint durch den Einsatz der TMC im Uart-Modus die automatische Zuordnung der Z-Motoren nicht mehr zu funktionieren. Musste also den zweiten Motor auf Z2 legen, dafür in den Pins E1 in Z2 umbenennen, dann klappte es. Den Motor auf E1 zu legen, funktionierte nicht."

Wundert mich, dass sich bei Dir auf E1 überhaupt was tut. Bei mir tat sich auf E1 nichts, der Motor wurde erst gar nicht angesteuert.
 
to top
#3
Mit sowas in der Art habe ich auch gerechnet, von dem Board liest man ja so einige Geschichten. Daher hat es mich echt stark gewundert, dass es auf Anhieb funktionierte. Ich habe allerdings echt keine Idee wieso der Motor so heiß wird, der bewegt sich ja nur einmal pro Layer ein kleines Stück, kein Grund selbst mit 2A so heiß zuw erden... Ich hoffe mal, dass an dem Board/den Treibern nichts defekt ist, sondern es nur rein softwareseitig ist. Ich werde morgen nochmal weitertesten...
Gruß
Julian

 
to top
#4
(26.05.2019, 22:12)JulianP schrieb: Daher hat es mich echt stark gewundert, dass es auf Anhieb funktionierte.

Vielleicht kann ich ja nicht mehr lesen, oder ich verstehe es einfach nicht: Was funktioniert da, wenn der Motor kochend heiß wird? Da funktioniert etwas offensichtlich nicht, wie es soll.
 
to top
#5
Du hast schon recht, das Funktionieren war auch mehr auf die Bewegung bezogen, der Motor dreht sich ja immerhin. Wink
Gruß
Julian

 
to top
#6
wundert mich eigentlich, dass du das kompiliert bekommst.
Bei mir hat er schon beim Kompilieren gemeckert, dass er den Pin für den zweiten Z-Motor nicht findet.

Erst nach dem Tipp von @AlWA hat es dann funktioniert.

hast du evtl. einen der Teiber in Marlin noch auf standalone oder den falschen Treibertyp eingestellt?
Alle sagten: Das geht nicht. Da kam einer der das nicht wusste und hat's gemacht Wink

Hier mal ein ganz wichtiger Link:  Einstell Fahrplan, oder wie stellen wir unsere Drucker ein und mehr
 
to top
#7
Danke für den Tipp @rebsam, ich habe tatsächlich vergessen, in Marlin den Z2 Treiber auch auf TMC2208 umzustellen... Da war ich wohl etwas voreilig. Naja, nach dem Umstellen war ich dann auch an dem Punkt, dass ich es nicht kompiliert bekomme. Seltsam, dass er es vorher kompiliert hat und es bis auf die Hitze sogar mehr oder weniger lief...
Naja, nun hab ich aber auch alles hinbekommen und der Calibration Cube druckt erfolgreich.

Vielen Dank an AlWA & rebsam für Eure Hilfe!
Gruß
Julian

 
to top
#8
Ich habe schon oft geschrieben, dass Marlin in Verbindung mit dem SKR noch ziemlich verbuggt ist. In dem Punkt ist Klipper fehlerfreier. Allerdings zickt bei mir Klipper immer wieder mit Octoprint rum.
 
to top
#9
Gutenn Abend !
Für alle wer uart nicht nutzt , oder kann nicht es zu nutzen )) wie ich )) und dann noch wie ich auf dem Treiber stat 0,11 , ein 0,1 Ohm wiederstand hat )) weil weit verbreitete
Vref= (Irms(TMC2208)*2.5) / 1.77 ist nur für Rsense = 0.11 Ом. Gültig, Für alle andere

Irms=325mv·Vref/(2.5(Rsense+20mΩ)·√2) Quelle Hier : https://gzhls.at/blob/ldb/c/9/4/2/ffa39ccd8323907ea35953b5f5e3ef9dfd3c.pdf

Das heist beimRsense= 0,1 Ohm wiederstand Vref(TMC2208) =(Irms(TMC2208)*2.5) /1,92 !!!!
 
to top
#10
Da würde mich interessieren, von welchem Hersteller die Treiber kommen!?
Gruß
Chris                    

Meine Schwiegermutter hat viel mit Konfuzius gemein,
nur das "z" wurde zum "s"...
 
to top
  


Möglicherweise verwandte Themen...
Thread Verfasser Replies Views Last Post
  [Frage] A4988 auf TMC2208 allg. Fragen... Gera 1 166 27.01.2020, 10:48
Last Post: James
  TMC2100 und TMC2208 verhalten sich stark verschieden Phonon 12 1.272 31.05.2019, 08:52
Last Post: Phonon
  TMC2208 per UART an Anycubic i3 Mega anbinden Mark79 3 3.775 04.05.2019, 10:03
Last Post: Mark79
Exclamation Klipper-Entwickler warnen vor TMC2208 im Stand-Alone-Modus ChrisB 16 2.255 01.04.2019, 09:42
Last Post: ChrisB
  Watterott TMC2208 Lötbrücken softcorn 3 660 28.03.2019, 19:21
Last Post: ChrisB



Browsing: 1 Gast/Gäste