Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.
  • Willkommen zur 3D-Druck-Community, einer nichtkommerziellen,
  • werbefreien und privaten Plattform rund um das Thema 3D-Drucken
  • vorrangig im deutschsprachigen Raum. Von User für User.
Hallo, Gast! Anmelden Registrieren


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Marlin ignoriert die eingestellten Beschleunigungswerte
#1
Moin,
ich habe ein Problem mit meinem Anycubic i3 Mega.
Marlin ignoriert die eingestellten Beschleunigungswerte.
(M204 P3500.00 R4000.00 T3500.00)
Wenn ich ihn nur bewege, übernimmt er alle Beschleunigungswerte.
Wenn ich beim Bewegen aber gleichzeitig extrudiere, ist die Beschleunig bei ca. 500mm/s2.
Meine Firmware ist https://github.com/davidramiro/Marlin-Ai3M-2.0.x/releases
Ich habe diese Binary benutzt: https://github.com/davidramiro/Marlin-Ai3M-2.0.x/releases/download/v2.0.0/Marlin2-Ai3M-v2.0.0_stock-drivers.hex

Das sind meine EEPROM Einstellungen:
Code:
>>>M503
SENDING:M503
echo:  G21    ; Units in mm (mm)
echo:Filament settings: Disabled
echo:  M200 D1.75
echo:  M200 D0
echo:Steps per unit:
echo: M92 X80.00 Y80.00 Z400.00 E99.55
echo:Maximum feedrates (units/s):
echo:  M203 X250.00 Y250.00 Z14.00 E80.00
echo:Maximum Acceleration (units/s2):
echo:  M201 X4000.00 Y3000.00 Z120.00 E10000.00
echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
echo:  M204 P3500.00 R4000.00 T3500.00
echo:Advanced: B<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> J<junc_dev>
echo:  M205 B20000.00 S0.00 T0.00 J0.02
echo:Home offset:
echo:  M206 X0.00 Y0.00 Z0.00
echo:Mesh Bed Leveling:
echo:  M420 S0 Z0.00
echo:  G29 S3 X1 Y1 Z0.00000
echo:  G29 S3 X2 Y1 Z-0.02000
echo:  G29 S3 X3 Y1 Z-0.02000
echo:  G29 S3 X4 Y1 Z-0.04000
echo:  G29 S3 X5 Y1 Z-0.02000
echo:  G29 S3 X1 Y2 Z0.04000
echo:  G29 S3 X2 Y2 Z0.06000
echo:  G29 S3 X3 Y2 Z0.06000
echo:  G29 S3 X4 Y2 Z0.06000
echo:  G29 S3 X5 Y2 Z0.08000
echo:  G29 S3 X1 Y3 Z0.02000
echo:  G29 S3 X2 Y3 Z0.06000
echo:  G29 S3 X3 Y3 Z0.08000
echo:  G29 S3 X4 Y3 Z0.10000
echo:  G29 S3 X5 Y3 Z0.08000
echo:  G29 S3 X1 Y4 Z0.02000
echo:  G29 S3 X2 Y4 Z0.04000
echo:  G29 S3 X3 Y4 Z0.06000
echo:  G29 S3 X4 Y4 Z0.06000
echo:  G29 S3 X5 Y4 Z0.06000
echo:  G29 S3 X1 Y5 Z0.00000
echo:  G29 S3 X2 Y5 Z0.00000
echo:  G29 S3 X3 Y5 Z-0.02000
echo:  G29 S3 X4 Y5 Z-0.02000
echo:  G29 S3 X5 Y5 Z-0.04000
echo:Endstop adjustment:
echo:  M666 Z0.00
echo:PID settings:
echo:  M301 P21.39 I1.55 D74.03
echo:  M304 P175.70 I32.50 D237.50
echo:Linear Advance:
echo:  M900 K1.05
echo:Filament load/unload lengths:
echo:  M603 L538.00 U555.00
Hat jemand eine Idee, was ich falsch mache?

Florian S
 
to top
#2
Was sagt denn der dazugehörige GCode?


Wer mit Bananen bezahlt, braucht sich nicht wundern wenn er nur Affen bekommt.
 
to top
#3
1. na ja, je nachdem wie die Settings in der Fimrware sind, ignoriert die Firmware alles was über ihrer eigenen Einstellung ist.
2. die von dier eingestellten Werte erreicht ein I3 im Leben nicht

Are you master of chaos or is chaos master of you?

 
to top
#4
(14.03.2020, 17:22)Aurillion schrieb: Was sagt denn der dazugehörige GCode?

Ich gebe einfach nur

Code:
M204 P3500.00 R4000.00 T3500.00
M83
G1 X200 Y200 Z10 E10; Die Beschleunigungswerte werden ignoriert

bzw

Code:
M204 P3500.00 R4000.00 T3500.00
M83
G1 X200 Y200 Z10; Die Beschleunigungswerte werden nicht ignoriert
In Pronterface zum Testen ein.
 
to top
#5
schau dir die max feedrates in der firmware an, auch für die E-Achse,
außerdem gibts bestimmt auch 2 sets an max acceleration parameter, einen für travel move und einen für extrude move

mit einem der firmware-settings kollidierst du.
Ein Leben ohne 3D-Druck ist möglich, aber sinnlos.
 
to top
#6
Zitat:schau dir die max feedrates in der firmware an

Das steht in Configuration.h:
Code:
/**
* Default Max Feed Rate (mm/s)
* Override with M203
*                                      X, Y, Z, E0 [, E1[, E2...]]
*/
#define DEFAULT_MAX_FEEDRATE          { 500, 500, 6, 60 }

//#define LIMITED_MAX_FR_EDITING        // Limit edit via M203 or LCD to DEFAULT_MAX_FEEDRATE * 2
#if ENABLED(LIMITED_MAX_FR_EDITING)
 #define MAX_FEEDRATE_EDIT_VALUES    { 600, 600, 10, 50 } // ...or, set your own edit limits
#endif

/**
* Default Max Acceleration (change/s) change = mm/s
* (Maximum start speed for accelerated moves)
* Override with M201
*                                      X, Y, Z, E0 [, E1[, E2...]]
*/
#define DEFAULT_MAX_ACCELERATION      { 3000, 1200,  60, 10000 }

//#define LIMITED_MAX_ACCEL_EDITING     // Limit edit via M201 or LCD to DEFAULT_MAX_ACCELERATION * 2
#if ENABLED(LIMITED_MAX_ACCEL_EDITING)
 #define MAX_ACCEL_EDIT_VALUES       { 6000, 6000, 200, 20000 } // ...or, set your own edit limits
#endif

/**
 * Default Acceleration (change/s) change = mm/s
 * Override with M204
 *
 *   M204 P    Acceleration
 *   M204 R    Retract Acceleration
 *   M204 T    Travel Acceleration
 */
#define DEFAULT_ACCELERATION          1500    // X, Y, Z and E acceleration for printing moves
#define DEFAULT_RETRACT_ACCELERATION  3000    // E acceleration for retracts
#define DEFAULT_TRAVEL_ACCELERATION   1500    // X, Y, Z acceleration for travel (non printing) moves

Da sehe ich jetzt aber nichts, was die Beschleunigungswerte verhinder könnte, die ich mit M201, M204 und M203 eingestellt habe, da
Code:
//#define LIMITED_MAX_FR_EDITING        // Limit edit via M203 or LCD to DEFAULT_MAX_FEEDRATE * 2
//#define LIMITED_MAX_ACCEL_EDITING     // Limit edit via M201 or LCD to DEFAULT_MAX_ACCELERATION * 2
auskomentiert sind.
 
to top
#7
Meine Leseweise:
Eben, durch die Auskommentierung hast Du die Befehle außer Gefecht gesetzt, oder?
 
to top
  


Möglicherweise verwandte Themen...
Thread Verfasser Replies Views Last Post
  FreeCAD -> Cura: Materialsubtraktionen werden ignoriert Ludolf 9 659 26.12.2018, 14:00
Last Post: gafu



Browsing: 1 Gast/Gäste